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INFINITY Software v6.5.6 

This minor release update includes adjustments to the INFINITY CAPTURE application to support the new 
INFINITY5-3 and INFINITY5-5 camera models.  Support for these two camera models is not available in the 
INFINITY ANALYZE application, which remains unchanged at release 6.5.5.  Third-party application support is 
available for the INFINITY5 series cameras using Micromanager, MatLab, MetaMorph, or ImagePro Premier, 
with the appropriate plug-ins downloaded and installed.    
 

 Camera device drivers 

 This release includes camera device drivers for all the INFINITY camera models that have been 
updated to enable the cameras to be fully recognized and supported on a Windows 10 Enterprise 
platform (32-bit and 64-bit).  Device driver support continues unchanged for standard Windows 10, 
Windows 8.1, and Windows 7 operating systems, on both 32-bit and 64-bit platforms.  

 

 INFINITY5 camera series 

 The following camera settings are persistently stored within the INFINITY 5-3 and INFINITY5-5 
camera models, so that the performance of the camera remains consistent when connected only to 
a display device with an HDMI input.   

 Ignore USB Power Requirements 
 Image orientation (flip/mirror) 
 Auto exposure target brightness 
 White Balance (color channel gains) 

 The INFINITY CAPTURE application will also retain the last camera settings in the (*.itw) file. 
 

 INFINITY CAPTURE & TWAIN interface 

 Device recognition is included for the new INFINITY5-3 and INFINITY5-5 camera models 

 A specific HDMI (1920 x 1080) video preview resolution is accessible from the dropdown and when 
selected the INFINITY5 series cameras will simultaneously stream to both USB3.0 and HDMI 
output ports.  Choosing any other Region of Interest (ROI) from the live preview resolution menu 
will immediately suspend the HDMI output. 

 While video streaming from the INFINITY5 series cameras is possible without need for a computer 
(USB3.0) connection, both the still image capture and the video clip acquisition require the USB3.0 
interface to the PC, and that the INFINITY CAPTURE application is running.  Still image capture 
can be initiated by pressing the button on the camera body, while video clip acquisition must be 
invoked from within the INFINITY CAPTURE application.  

 Flip & Mirror settings enabled through INFINITY CAPTURE will be retained in the INFINITY5 series 
cameras (even with power-down), so that the camera image will have the expected orientation the 
next time it is viewed, even when only connected via HDMI cable. 

PRODUCT NEWS #12-CORP-?? 
Lumenera’s INFINITY 3-3UR 2.8 
Megapixel CCD USB 3.0 Camera 
New Product Introduction 
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 Setting the image brightness when the Auto-Exposure (AEC) option is enabled will allow the target 
value to be stored in both the application and within the camera itself.  This is how the target 
brightness setting is configured for the camera to use when only connected to an HDMI device. 

 For the INFINITY5 series cameras, the HDMI live preview is limited to 16.66ms exposure times, in 
order to support the 60fps requirement.  The auto-exposure feature employs a combination of 
exposure and gain controls to reach the selected image brightness target value.   

 

INFINITY ANALYZE 

 Device recognition is not available for the INFINITY5 series cameras in this release of INFINITY 
ANALYZE.   

 There are no software revisions to the INFINITY ANALYZE package with this release.  The revision 
number for INFINITY ANALYZE remains at 6.5.5 

 

3rd-Party Package Support 

 Updates have been made to the Micromanager, Metamorph, ImagePro Premier, Matlab, and 
LabView plugins to support all INFINITY camera models with up-to-date releases of these 3

rd
-party 

packages.  Check the Support area of the Lumenera web site under both Industrial and Microscopy 
Drivers & Downloads for the most recent versions. 

 

INFINITY Software v6.5.5 

This minor release update is simply to include support for the INFINITY EP camera in both the INFINITY 
CAPTURE and ANALYZE applications.   

 INFINITY CAPTURE & TWAIN interface 

 Device recognition is included for the new INFINITY EP camera model 

INFINITY ANALYZE 

 Device recognition is included for the new INFINITY EP camera model 

 

INFINITY Software v6.5.4 

Minor corrections have been made to both the INFINITY CAPTURE and ANALYZE applications.  No alterations 
have been made to device driver files in this update. 
 

 INFINITY CAPTURE & TWAIN interface 

 Exposure range calculations were incorrectly represented for the INFINITY3S-1UR camera model 
in the previous INFINITY CAPTURE & TWAIN release.  The exposure range and camera response 
is now performing as expected. 

 The INFINITY3-6 camera model could produce corrupted images via the TWAIN interface, if the 
live preview resolution was larger than the capture resolution.  This issue has been corrected. 
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INFINITY ANALYZE 

 The exposure slider adjustment in the Multispectral Capture Wizard has been modified from a linear 
implementation, to a logarithmic implementation, to allow for adjustments in smaller exposure time 
increments when using shorter exposures. All other characteristics of the MultiSpectral Capture 
Wizard remain unchanged.  

 Exposure range and frame rate calculations were incorrect in the upper region of the exposure 
range (between 300ms and 500ms) for a number of the INFINITY camera models.  The updates 
have corrected the performance issues that impacted the INFINITY2-1R, INFINITY3-1UR, 
INFINITY3-3, INFINITY3-6, and INFINITY3S-1UR camera models.  

 

INFINITY Software v6.5.3 

This release provides full support for the INFINITY3S-1UR camera model, and includes minor updates to the 
INFINITY CAPTURE and TWAIN interfaces to better support features in the new camera model. A few 
alterations have also been made to the INFINITY ANALYZE application, in addition to extended support for the 
INFINITY3S-1UR camera model. 
 

 INFINITY CAPTURE & TWAIN interface 

 
 The default frame rate for the INFINITY3S-1UR camera model is preset to the second-fastest.  An 

option has been added to the INFINITY CAPTURE menu to enable the fastest frame rate mode, by 
activating the checkbox to the left of the exposure slider control.  Under some conditions, there 
could be a slight alteration in image quality when operating at the fastest frame rate. 

 

 

INFINITY ANALYZE 

 

 The default frame rate for the INFINITY3S-1UR camera model is preset to the second-fastest.  An 
option has been added to the INFINITY ANALYZE Help -> Settings… dialog where the camera’s 
live preview output can be optimized for the fastest frame rate. Under some conditions, there could 
be a slight impact on image quality when operating at the fastest frame rate. 

 Use the Capture Options panel settings to enable both Capture full field and Use snapshot mode to 
force image acquisition in single-tap output mode, if exposure times are below 45ms, and the live 
preview is set to optimize the preview frame rate. 

 The ability of the software to retain the most recently placed micrometer bar length has been 
improved.  The capability built into earlier versions of the software would not retain the length 
setting correctly when switching between presets that were using different measurement units. 

 The INFINITY ANALYZE User’s Manual has been updated for appearance and includes minor 
alterations to accommodate changes in the software made since release 6.5.1 
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INFINITY Software v6.5.2 

This release includes updates to both the INFINITY CAPTURE (incl. TWAIN) and the INFINITY ANALYZE 
application packages, with both bug fixes and improvements.  Preliminary support for the upcoming 
INFINITY3S-1UR camera model is also included.  
 

Camera Device Drivers 

 
 Device drivers have been included for the INFINITY3S-1UR camera model 

 INFINITY CAPTURE & TWAIN interface 

 
 Corrected an issue that prevented Image acquisition from functioning correctly when the Auto 

Exposure Correction (AEC) was enabled 

 Resolved an issue that meant the video clip playback button was disabled if the user selected to not 
overwrite an existing video clip during the save operation 

 Several alterations were made to the Help -> About dialog box, including the addition of the USB 
connection being used (USB 2.0 or USB 3.0), the FPGA version, and the ability to launch an e-mail 
directed to the Lumenera Technical Assistance Centre (TAC) team 

 A keyboard shortcut key has been implemented so that <Ctrl> G will result in an image acquisition.  
In previous releases the only mechanism for using the keyboard to acquire an image would be to 
access the menu dropdowns with the <Alt> key.  For example: <Alt> F C would invoke an image 
capture from the File menu.  This capability remains enabled 

 Corrected a problem with the live preview being shifted to the right whenever the display zoom 
percentage was altered.  Previously, a blank white area replaced the right side of the live preview 
window until the window dimensions were adjusted with a mouse drag operation 

 The display frame rate for the camera under the current exposure time and Region of Interest (ROI) 
settings is now included in the live preview window title, when enabled from the Options menu.  
Note: under certain conditions it can take a minute or two for the displayed frame rate to stabilize on 
the actual camera output frame rate. 

 The live preview size and position are now restored to the location and dimensions that were in-use 
when the application was last closed 

 The USB 3.0 camera models will switch from quad-tap mode (fast frame rate) to single tap mode 
when the exposure time reaches a point where quad-tap output is no longer beneficial to achieving 
the fastest frame rate.  When the exposure time is reduced below the threshold, the quad-tap mode 
will resume.  Single tap mode will always be used for image capture when the Options -> Capture 
Quality -> Optimize for Quality is enabled 

 Corrected a problem that would display a false error showing that exposure time had been 
exceeded when the maximum extended exposure time was chosen on the exposure slider 

 Two new light source types have been included in the Options -> Light Source dropdown list.  The 
color Correction Matrices (CCM) for LED and Halogen light sources are now available 

 

INFINITY ANALYZE 

 

 Performance improvements were implemented in the Multispectral Capture Wizard measurements 
which will provide users with a few options for acquiring frames.  If the live update is active, the 
image acquisition takes place more quickly in this latest release.  A new tab has been added to the 
Help  Settings dialog provides the choice of using one of three acquisition methods in the 
Mutlispectral Capture Wizard.   The default mode is referred to as Normal, and the two additional 
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methods provide for Unity Gain and Exposure Simulation modes, as alternatives in controlling the 
camera behavior within the Wizard.  Select Unity Gain if the preferred method of live update 
involves increasing the camera gain.  When the capture button is clicked, the application will return 
the gain setting to 1 and automatically apply an exposure time that will acquire an image with the 
equivalent brightness.  Select Exposure Simulation if the preferred method is to increase the 
exposure setting to brighten the image, but to have the application use a digital amplification to 
simulate the request exposure for the live update.  The actual requested exposure time will be used 
for the acquisition.  With this mode, setting the desired camera exposure time is necessary, such 
that any exposure time above this value will be achieved by digital amplification in the live update 
window.  All three methods have been introduced to assist in the framing and focusing on the 
sample while obtaining fast frame rates under various illumination conditions.  Refer to the 
INFINITY ANALYZE User’s Manual for a more complete set of instructions on using these settings. 

INFINITY Software v6.5.1 

 
This release includes updates to the INFINITY ANALYZE package, with bug fixes and improved support for the 
INFINITY3-6 camera model.   

 INFINITY CAPTURE & TWAIN interface 

 No changes are included to the INFINITY CAPTURE or TWAIN applications 

INFINITY ANALYZE 

 If measurements or annotations were added to a captured image that had been saved to disk, and 
the image window was closed using the “X” in the upper right corner… selecting ‘yes’ to overwrite 
the existing saved image would replace the image with a file extension that matched the selected 
type, but the file was saved as a native SIF file format.  This prevented it from being opened, unless 
the extension was renamed to “.sif” and the image opened in ANALYZE, where it can be re-saved 
correctly. 

 Images being saved from the INFINITYX-32 (or X-21) camera were not being saved if annotation 
graphics or measurements were displayed in the live preview window.  This limit was due to large 
file formats exceeding the GDI graphic library limits.  These types of overlays have been disabled in 
the updated release to allow the large images to be saved correctly.  Annotations and overlays are 
restricted on these camera models in this release. 

 Images previously saved to disk were not being added to the database because the full path name 
from the saved image was used as the file caption, which could not accept the “\” character.  The 
database caption now only stores the image file name portion, and excludes the path. 

 When attempting to drag records from the database into an Excel spreadsheet, inadvertently 
releasing the mouse button while still within the database window was causing the application to 
crash.  Releasing records within the database window is disabled. 

 Images saved as TIF file format could not be imported into to the Field Group or opened within the 
Multispectral Capture wizard, due to a conflict with the image format.  This has been corrected, and 
TIF files can now be opened. 

 The ability to apply the Look-Up Table (LUT) to a captured image had been removed, but has now 
been restored under the Adjust  Lookup Table menu item 

 When the Capture full field option was un-checked, the resulting image was saved to disk as a 
vertically inverted image.  This has been corrected. 

 Large files could not be processed with Multi-Focus Composition (MFC) or Panorama stitching, 
preventing these operations from working with output from the INFINITY2-5 and INFINITY3-6 
camera models.  A new menu item has been added to split the MFC operation into two parts for 
images taken on a stereoscope.  The alignment step should be performed first, using the Field  
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Shift correction for stereomicroscope, followed by the MFC step. The alignment step is not required 
on images collected using an upright scope.   

 Panorama stitching now requires a 50% overlap in adjacent images collected to the field group. 

INFINITY Software v6.5.0 

This release includes updates and enhancements to both the INFINITY CAPTURE and INFINITY ANALYZE 
packages.   

Camera Device Drivers 

 Included device driver files for the new INFINITY3-6UR and INFINITY3-9UR camera models.  
These new camera models are to be released in 2015. 

 A firmware update is recommended for all INFINITY3-3UR camera models to correct an issue 
where snapshot images could produce a corrupted output.  See the Firmware update link provided 
on the Support  Microscopy (USB)  Drivers / Software downloads web page in the INFINITY 
Camera Software v 6.5.0 section. 

INFINITY CAPTURE & TWAIN interface 

 Incorporated support for the INFINITY3-6UR & INFINITY3-9UR camera models 

 Imposed an exposure time constraint on the use of quad-tap mode.  When the exposure time is 
increased to a point where the quad-tap output frame rate can no longer be obtained, the camera 
will revert to single tap mode 

 When an image is saved, the filename will appear in the captured image title bar 

 Removed the broken functionality that exports INFINITY CAPTURE camera settings into an 
INFINITY ANALYZE preset 

 Corrected an issue where the lower exposure slider would become unresponsive after 
enabling/disabling AEC. 

 The image capture function for INFINITY3-3UR and INFINITY3-6UR cameras will use a reduced 
frame rate to ensure optimal image quality controlled by a setting under Options  Capture Quality. 

 

INFINITY ANALYZE 

 Incorporated support for the INFINITY3-6UR & INFINITY3-9UR camera models 

 The contents of the File dropdown menu have been split and the functions from the lower portion 
have been re-located into a new Camera Menu dropdown, appearing to the right of the File menu 

 A new Wizard is provided to facilitate the capture and display of fluorescence channel images in a 
color composite form.  The Camera  Capture  Multispectral Capture menu invokes the wizard.  
Prior to being able to acquire images, the Camera  Capture  Multispectral Settings must be 
configured.  New toolbar icons have been added to support these menu functions.  Refer to the 
User Manual for further details 

 A utility has been added to provide for batch file format conversion from native *.SIF file format into 
JPG, BMP, or TIFF.  This function is accessed from the File menu within ANALYZE.  It allows for 
the selection of a group of files to process, and it produces copies of those selected SIF files in the 
same folder, but with a different file extension. 

 The ability to save image files in ‘raw’ format has been removed from the application File Save 
options – this format contained no header information and there were no functions that could read 
or open a file in raw format 

 A new button has been added to the Camera Controls panel, allowing the Live Preview to be 
started / stopped with a single mouse click.  This extends capability of the existing function File  
New for video preview 

http://www.lumenera.com/support/downloads/microscopy-downloads.php
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 The circle outline and the number printed within the circle are now both set when the graphic color 
for measurement is specified.  A bug in release 6.4.1 caused the text to only appear as black 

 A Reset function has been added to the top of the Camera Control Extended panel, to allow the 
Saturation, Hue, Brightness, & Contrast to be restored to their default values 

 Image window title bars are now updated with the filename used to save the image 

 The Field  Math menu now includes the ability to ‘Add’ images stored in the field group 

 The dropdown list for Alternate exposure and gain is now preserved from one session to the next 

 Corrected an issue where saving captured images directly to file with any subsampling option (x2, 
x3, or x4) enabled would result in the image file being corrupted. 

INFINITY Software v6.4.0 and 6.4.1 Release 

This release introduces a number of enhancements relating to new product introductions, the INFINITY 
ANALYZE package, and the INFINITY CAPTURE and TWAIN interface.   

Camera Device Drivers 

 Included device driver files for the new INFINITY3-3UR camera models 

INFINITY CAPTURE & TWAIN interface 

 Incorporated support for the INFINITY3-3UR camera models 

 Specific to the INFINITY3-3UR camera, a modification has been implemented to the Options  
Preview Quality.  For this camera model the Optimized for Speed will enable the camera to output 
at the fastest possible frame rate, while the Optimized for Quality will limit to a lower frame rate.  

INFINITY ANALYZE 

 Live video preview performance has been improved with a significant increase to the display frame 
rate capability on all camera models. 

 The ability to capture short, compressed video clips has been added to the software.  This newly 
introduced capability has performance limitations, specifically with the larger resolution sensors 
running at fast frame rates, in this release.  Performance improvements are anticipated in 
subsequent releases.  The AVI file is stored according to the folder location specified in the Capture 
Options: Save to File location, using the file prefix provided there.  There is no video file playback 
capability available within INFINITY ANALYZE, so a folder open option is presented adjacent to the 
video record button, allowing a browser window to open.  The user selects an AVI file from the list, 
and chooses a 3rd-party tool to display the video clip.  Video clip capture performance depends on 
the processor, memory, and hard drive storage speeds. 

 The default behavior of the Live Preview window is to freeze when measurement operations are 
initiated in that view, to ensure that the field of view does not alter during a measurement operation.  
An option has been added to the Help  Settings panel to allow for user to request that the preview 
remain live, if desired. 

 Project Tags are now persistent between ANALYZE sessions 

 The Calibration dialog now includes a dropdown featuring presets for common measurement units 
(um, mm, mil, inch) 

 Extended exposure time can now be selected to switch the camera into a new acquisition mode to 
extend the camera exposure time up to 2 seconds,  The camera will change from streaming video 
to sequential snapshots when the exposure time is increased above 500 ms. 

 The Capture Options pane now includes the ability to specify an Alternate Gain, along with the 
existing Alternate Exposure for captured images.  This feature also allows for specified pairs of 
exposure and gain settings to be stored during the session, for quick reference or retrieval.  This 
function reduces the steps required to acquire fluorescence images  
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 Annotation tools now remain in edit mode once activated, until the operator selects a different 
action, or chooses the Edit  Abort menu item. This allows for easier alignment and re-positioning 
of placed annotation objects. 

 Performing measurement functions such as Point-to-Point, Polyline, or Measure  Calibrate, can 
now be constrained to either horizontal or vertical motion while holding down either the Ctrl or the 
Shift keys (respectively), while moving the mouse. 

 The File menu includes a new feature called ‘Stretch Histogram’, which can be enabled on the Live 
Preview window.  It invokes a Look-Up Table (LUT) configured to enhance the image under light 
challenged applications.  This function can be helpful when framing and focusing on a fluorescence 
sample.  The LUT will remains active until cancelled by toggling the option in the File menu, or 
using the Reset LUT icon above the histogram auxiliary window.  If the LUT is active it will apply to 
a captured image. 

 An option has been added to the Help  Settings dialog, specific to the INFINITY3-3UR camera.  If 
the fastest possible video frame rates are desired, the option to select a preview quality that is 
optimized for speed will result in a performance increase for the live preview on most computers.  
The Live Preview window must be closed and re-opened (File  New for video preview), to switch 
between display processing modes 

 Corrected a problem with the Print operation that resulted in the incorrect scaling / position of 
annotation objects with respect to the underlying image.  

 Corrected the behavior of the multiple camera selection dialog that appears on application launch 
when more than one INFINITY camera is detected, such that when Cancel is selected, the 
application launch is aborted. 

 Corrected an implementation issue introduced in release 6.4.0, that caused the live preview window 
to flicker continually while the Save As dialog was displayed, when the Verify file name option was 
enabled. 

 Improved the performance of the Continuous auto exposure over what was introduced in release 
6.4.0 

 Improved the Extended exposure time performance for CMOS cameras over what was introduced 
in release 6.4.0 

 For the INFINITY1-2CB camera model, an option is available in the Help  Settings panel to 
Optimize live preview for frame rate, which allows the camera to operate up to 15fps.  A horizontal 
segmentation may be detected across the image in this mode.  Enable the Capture full field under 
Capture Options to produce a captured image without the segmentation.  

INFINITY Software v6.3.0 Release 

This release introduces a number of enhancements to the INFINITY ANALYZE package.   

Camera Device Drivers 

 Adjusted INFINITY1-1C device driver to correct incompatibility occurring with some Windows 7 
computers 

 INFINITY2-3C camera device driver updated. 

INFINITY CAPTURE & TWAIN interface 

 Corrected issue where captured image color did not match the live preview 

 Established persistence of window position in dual monitor configurations, to prevent the live 
preview from returning to the main monitor location 

INFINITY ANALYZE 

 Refer to the INFINITY ANALYZE User’s Manual for Release 6.3.0, which has been updated with 
the changes to the user interface and inclusion of the new features and functions. 
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 Measurement on live preview is now available.  Users can take measurements without the need to 
first capture an image.  The live preview is temporarily frozen while measurement operations are 
underway, but the live updates resume when the measurement tool is closed.  A calibration preset 
must be active for accurate measurement results at a given magnification.  

 The ability to define an ROI in a live preview window or on a captured image is now provided.  
Frame rate increases are realized when using a cropped ROI invoked through the Adjust  Crop 
menu option.  The area outside the active ROI can be masked.  A cropped selection from a 
captured image can be saved to provide an exactly dimensioned image extract to save to file, if 
desired.   

 Dynamic bitmap overlay is now available as Project Tags, from the Annotate menu.  Define both 
fixed and dynamic text or image overlay to be added automatically to captured or live preview 
images.  Time / date or project IDs can now be easily added to any images. 

 Micrometer placement options have been altered to minimize the chance of specifying an 
incorrectly labeled micrometer bar on an image.  The length of the bar is determined by the numeric 
value entered for the label text.  If desired, the automatic label can be omitted and a custom label 
can be added manually as an annotation. 

 Direct export of measurement records into a new Excel spreadsheet has been added to the 
Measure menu 

 Measurement operations now include a temporary line from the current vertex to the start point for 
easier tracking 

 Polyline measurements now support both vertex placement and freehand drawing interchangeably 

 The ability to select and delete an individual measurement has been implemented 

 All Annotation object text and graphic properties are controlled through a single dialog with multiple 
tabs. 

 Annotation objects and Project Tags can be duplicated from a captured image onto the live preview 

 Annotation objects overlaid on the live preview are preserved as annotation objects in the captured 
image, and can be manipulated after the capture. 

 The Live Preview window can be made to remain visible when images are captured, by choosing 
an option on the Help  Settings menu 

 A new option allows for captured images to be acquired using a Snapshot mode that provides for a 
lower image noise in captured images, when specified 

 The Measure Options dialog now provides for the selection of a comma (,) or a period (.) as the 
decimal indicator used for measurement reports in the annotations and in the measurement 
auxiliary window. 

 The File  Time Lapse Capture menu item has been removed.  Time Lapse is now controlled only 
from the Camera controls pane 

 Changes to the way annotation objects are managed meant that the Adjust  Overlay [color / size] 
menu functions are now obsolete.  Use the Annotate  Properties to change annotation 
appearances. 

 Convert into Bitmap has been removed from the Annotate menu since bitmap overlays can now be 
managed dynamically using the Project Tags tool. 

 A green progress bar replaces the live preview window during image capture operations.  This is of 
specific benefit when image averaging or pixel-shifting functions are enabled. 

 Image acquisition parameters have been adjusted to correct color shift observed with some camera 
models, between the appearance of the live preview when compared to the colors captured in the 
still image. 

INFINITY Software v6.2.0 Release 

The following list summarizes the highlights for this 6.2.0 release: 
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Camera Device Drivers 

 Added support for the new INFINITY3-1UR camera. 

INFINITY Software v6.1.0 Release 

This release includes several device driver updates, as well as improvements to performance and some bug 
fixes for INFINITY ANALYZE.  

Camera Device Drivers 

 Device driver files for the INFINITY2-3C camera have been updated to correct a problem with 
captured images that were all black in INFINITY CAPTURE.  This timing problem was only evident 
on some computers. 

 An update to the INFINITY2-1 device driver fixes an issue present on some Windows 7 computers. 

 Improved frame rate range adjustments included in the device drivers for the INFINITY2-1R and 
INFINITY2-5 camera models.  

 An improvement to the INFINITY2-5 drivers to better manage transitions between clocks.  

INFINITY CAPTURE & TWAIN interface 

 No changes. 

INFINITY ANALYZE 

 The area WB (white balance) function has been revised since release 6.0.0 where performance 
was compromised on several camera models. 

 Camera frame rates have been configured to operate at their fastest speeds. 

 Closing the histogram window removes additional processing that was impacting the frame rate 
performance for the INFINITY1-5 and INFINITY2-5 models on some computers. 

 Certain computers experienced lock-up with ANALYZE when capturing images from the 
INFINITY1-3C camera model.  The application has been altered to correct this issue. 

 

INFINITY Software v6.0.0 Release 

This release incorporates improvements to the installation package, device driver updates, and some nice 
additions to the INFINITY ANALYZE package.  The locations of some application-related files have been 
altered to better accommodate Windows 7 and VISTA permissions. 
 

Camera Device Drivers 

 Improvements to the INFINITY1-2CB exposure controls allow this frame rate-centric camera to 
respond more like an exposure-centric camera. 

INFINITY CAPTURE & TWAIN interface 

 Changed location of Last Settings file to overcome write protection issues as follows:  
 On VISTA & Windows 7 – C:\Program Data\Twain_32\INFINITY\ 

 On Windows XP – C:\Documents and Settings\All Users\Application Data\TWAIN_32\INFINITY\ 
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INFINITY ANALYZE 

 Now includes dynamic window zoom for both live preview and captured images. 

 New Cell Counting menu item available on the Measure menu allows for interactive thresholding 
and quantitative results based on pixel intensities. 

 The image title bar is updated with the image file name as soon as it has been saved. 

 Micrometer bar text and length are now associated to the active calibration. 

 User Manual has been fully updated to reflect all menus and dialogs. 

 User interface is now available in 7 different languages. 

 Help menu provides direct access to video tutorials available on the Lumenera website. 

 New Annotation menu item creates a bitmap overlay image from displayed graphics. 

 
dialog, on a new tab. 

 Photometry auxiliary window displays pixel intensity distribution for measured areas. 

 The camera presets file (containing calibrations) is now located in this folder location: 
o On VISTA & Windows 7 -  

 C:\users\[User Name]\AppData\Roaming\INFINITY ANALYZE\ 

o On Windows XP -   
 C:\Documents and Settings\[User Name]\Application Data\INFINITY ANALYZE\ 

 

Known Issues 

 Frame rate of the INFINITY1-2CB is limited to 10 fps, but can be extended to 15 fps in INFINITY 
CAPTURE. Note that vertical bands may be visible, impacting image quality. 

 Frame rate of the INFINITY1-2CB is limited to 5 fps in INFINITY ANALYZE, but will be increased in 
a subsequent release. 

 INFINITY ANALYZE does not currently take advantage of the modified ‘exposure-centric’ behavior 
that has been implemented for the INFINITY1-2CB camera, and included with INFINITY 
CAPTURE. This will be addressed in a subsequent release. 

 

INFINITY Software v5.0.6 Release 

The following list summarizes the highlights for this 5.0.6 release: 

INFINITY ANALYZE 

 Added the default previewing video mode for the INFINITY2-5 camera. 

Camera Drivers 

 Improvement of the exposure and gain properties control. 

  
 

INFINITY Software v5.0.5 Release 

The following list summarizes the highlights for this 5.0.5 release: 
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Camera Drivers 

 Added support for the new INFINITYLiteB cameras. 

 Improved support for the new INFINITY1-2B cameras. 

 

INFINITY Software v5.0.4 Release 

The following list summarizes the highlights for this 5.0.4 release: 

 

Camera Drivers 

 Added support for the new INFINITY4-11 cameras. 

 Added support for the new INFINITY2-5 cameras. 

 Added support for the new INFINITY1-2B cameras using the SOI image sensor. 

 

Upgrade to new API version 2.1.0.241 

 Improve Windows 7 support. 

INFINITY Software v5.0.3 Release 

This section describes all the additions and updates we have made to the latest release of the software: 

Camera Drivers 

 Added CIM3 support for INFINITY2-1 and INFINITY2-2 cameras. 

 

INFINITY Software v5.0.2 Release 

The following list summarizes the highlights for this 5.0.2 release:   

Installation and Camera Drivers 

 The installation process has been revised to include a screen prompting for the INFINITY camera to 
be disconnected from the PC prior to continuing.   

 New driver file updates are included to correct an issue with the INFINITY4-11 and Lw11057-SCI 
models that could result in corruption of the live video preview.  Currently does not support external 
signaling of start of frame in Video mode (GPO4: Video SoF). 

 Corrected an issue where pixels would not fully saturate at default gain for the INFINITY1-5 model.  
In addition, the following Still Mode properties have been enabled: 

 STILL_EXPOSURE 
 STILL_GAIN 
 STILL_GAIN_RED 
 STILL_GAIN_GREEN1 
 STILL_GAIN_GREEN2 
 STILL_GAIN_BLUE 
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 STILL_STROBE_DURATION 

 Corrected issue for the INFINITY4 and Lu330 camera models with driver signing for Windows Vista. 

 Also improved quality of Brightness, Contrast and Gamma in 16-bit mode. 

 

INFINITY ANALYZE 

 ANALYZE Settings files have been relocated to the standard Windows folder location for 
Application Data, providing better compatibility with future releases of the O/S. This new location 
will be different on XP and VISTA platforms: 

 
 
For XP: 

 [Drive:]\Documents and Settings\All Users\Application Data\INFINITY ANALYZE\ 

 
For VISTA: 

 [Drive:]\Program Data\INFINITY ANALYZE\Settings 

 
 A problem has been rectified with saving new camera Presets. The original release of INFINITY 5.0 

introduced a problem resulting in ANALYZE failing to store the camera white balance settings. 
When a Preset was restored, the appropriate color gains were not being set on the camera.   

 An incorrectly imposed restriction on number of decimal places allowed in the Measure Options 
dialog has been removed. Entry of any value less than 2 was not permitted in the first releases of 
the 5.0 version. 

 An enhancement has been added to the micrometer bar placement allowing the previously selected 
location to be used again in the current image. The option is presented in the pop-up dialog after 
using the mouse to select a location in the image. This allows for the micrometer bar to be easily 
placed in a consistent location on all images, if desired.  

 Italian language files have been added to the installation, and the additional entry may now be 
selected from the View  Language menu option. 

 The ANALYZE Advanced Features USB-Key is now being distributed as a driver-less device, 
making for a simpler installation supported across more O/S platforms. The Release 5.0.2 of 
INFINITY ANALYZE is required to take advantage of this new style of USB key. 

INFINITY Software v5.0.1 Release 

Includes a correction to the driver for the INFINITY1-3 model. This patch release is identical to the 5.0.0 release 
in all respects for INFINITY CAPTURE and ANALYZE applications. 

INFINITY Software v5.0.0 Release 

The following list summarizes the highlights for this 5.0.0 release. Details can be found below, with even more 
information available in the Release Notes and product documentation. 

 
 64-bit drivers are now available for all INFINITY cameras on Windows platforms 

 ANALYZE now includes a FULL SCREEN mode 

 Preview grid pattern artifacts have been eliminated from ANALYZE 

 Bitmap Overlay added to Live Preview and Captured images in ANALYZE 

 CAPTURE can now export camera settings to a named ANALYZE preset 

 ANALYZE now offers a Simple layout for demos and first time operators 
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Camera Drivers 

 Added support for 64-bit Windows XP and Windows Vista operating systems. 

 All drivers are digitally signed for Windows Vista operating systems. 

 Added support for new revision of INFINITY2-2 cameras. 

INFINITY CAPTURE 

 New function to export current camera settings into an INFINITY ANALYZE preset. 

 Added additional 75% zoom mode to preview zoom control. 

 Improved AVI filenames when converting a RAW AVI file to a standard AVI file. 

INFINITY ANALYZE 

Changes to the Layout: 

 On initial start-up of the software, the first-time user will be presented with ANALYZE shown in a 
simple configuration.   

 New options to quickly modify the application layout are provided as Simple Mode and Enable All, 
available from the View Menu. 

 A new Full Screen display function has been added. This feature allocates the maximum amount of 
the display for either the live preview or for captured images. The application can switch in and out 
of Full Screen mode by using the View menu, or with a simple press on the <Esc> key. 

 The contrast of the status bar has been improved by making the background color black. 

 Some toolbar icons used for image positioning have been removed to reduce clutter. These seldom 
used navigation functions are now accessible only from the View menu, as items labeled as Center 
and Corner.  

 The Field Menu entry formerly labeled as Vector Arithmetic has been changed to Math. 

 The buttons labeled Video On/Off have been removed from the CAPTURE Control panel, providing 
more space.  

 The sequence of Control panels (from top to bottom) has been rearranged for greater ease of use.   

 The Measure Menu has undergone a transformation to make the most commonly used options 
readily accessible and to improve the ease of use for common measurement tasks. The Calibration 
and Micrometer functions have been moved onto this menu. 

 Revisions to the Micrometer function allow the bar and the text to be re-positioned anywhere on the 
image by placing them in the annotation layer.  

 The distance or length measurements tool formerly labeled as Caliper, has been changed to Point 
to Point. 

 A new option has been added to the File menu called Close All Images. This feature pops-up a 
single confirmation dialog prior to closing down all displayed images in the working area. 

 Warnings and information messages now alert the operator when the Field Group memory is 
consumed, or if the number of fields has been used. 

Camera performance and controls:  

 The Camera Control panel now includes a new option to provide a Continuous Auto Exposure 
function.   

 In previous revisions of the ANALYZE package the live preview from certain high resolution camera 
models (notably the INFINITY2-3, INFINITY1-5, and INFINITY4-11) would often produce a grid 
pattern appearance that varied based on the display window dimensions. While this artefact was 
observed only in the live preview and not on captured images, it was a distraction and an 
undesirable characteristic. Modifications have been made to the display capabilities to help 
eliminate or minimize this problem.  
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Other functional changes 

 A Bitmap Overlay function has been added to both the Live Preview display and to Captured 
images.   This function is accessed using the File  Bitmap Overlay… menu  

 The newly designed Grid Options function allows for the origin and size of the grid spacing to be 
easily defined.  A new tool allows for the operator to specify the grid parameters using the cursor 
position on the captured image.  

 It is now possible to change the units of measurement without re-calibrating.   

 A new auxiliary window called Photometry has been added to ANALYZE.  It reports pixel intensity 
values for any defined measurement areas.   

  


