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INFINITY ANALYZE 7 – Release Notes 

Latest Software Release – 7.1.1 

Date  February 24, 2023 
Windows 7.1.1.66 
Mac 7.1.1.66 

The following items have been addressed in the current release 

Improvements Implemented 

Support for two additional, new INFINITY8-series camera models [i8-3, i8-9] is included in both 
the Windows and Mac version of the INFINITY ANALYZE application. 

Image file compression levels for JPG images have been included in the File > Preferences 
section.  Selections have been added for Best, Good, Moderate, Average, or Limited, based on 
image quality over compressed size. The standard compression used in previous releases 
corresponds to the user-selectable level listed as Good.   

Issues Addressed 

A Micrometer bar displayed in the Live Preview image will now resize dynamically when a 
Preset referencing a different Calibration, is activated.  This corrects an issue introduced in  
release v7.1.0.1215 which prevented the Micrometer bar length from updating in the Live View, 
when switching Presets.  

The Area White Balance operation has been corrected.  Mouse click coordinates were being 
incorrectly converted, meaning that pixel intensity values from elsewhere in the image were 
being used.    

The application now retains and restores the operator’s last-used image storage file type 
selection on launch.  In the previous release, the TIF format was being activated each time the 
application started. 

Monochrome images were being displayed with an inverted grey-scale on the Mac platform. 

With the mouse focus on the exposure slider, scroll wheel activity could previously result in a 
stack of exposure adjustments that would crash the application. 

Menu references to an unused Photometry docked window have been removed 

The internal video playback mechanism was unable to playback recordings on Mac.  This 
functionality has been removed such that a default video player will handle the playback 

Options available to initiate a Measure > Calibrate operation have been revised to eliminate 
inconsistencies in message and the state of performing a calibration. 

Known Issues 

The White Balance and Area WB functions are not working for the INFINITY5-5C camera. 
Recommended v7.1.0 be installed, until this issue is resolved. 

An inconsistency with Exposure Control impacts the INFINITY3-3UR and INFINITY3-6UR 
models in this release.  The issue may occur when exposure is in the range of approximately 
230 and 500ms.  Exposure time response is accurate the first time through a Sequence, 
however, on subsequent runs of the Sequence, the camera exposure time will likely be 
restricted to the lower end of that range.  Exposure times below or above the specified range 
are responding correctly. 
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Previous Software Release – 7.1.0 

Date  Sept. 10, 2021 
Windows 7.1.0.1215 
Mac 7.1.0.1215 

The following items have been addressed in the current release 

Improvements Implemented 

Support for the new INFINITY8-series camera models [i8-2, i8-8, & i8-20] is included in both 
the Windows and Mac version of the INFINITY ANALYZE application. 

With the release of INFINITY ANALYZE v7.1.0, a Windows 10 operating system is required for 
installation on a PC.  This is due to Microsoft application signing requirements. 

Region of Interest (ROI) options can be selected from a dropdown list of standard image sizes, 
available in the Capture Options panel.  Any selected ROI size can be stored in an active 
Preset. 

Improvements to the auto-exposure algorithm allow it to settle at short exposure times.  New 
user controls have been included on the File > Preferences… > Display panel, providing 
control over the auto-exposure refresh rate.  Setting a less frequent refresh interval can help 
stabilize the auto-exposure behavior, when enabled. 

The INFINITY8-2M camera model includes a High Conversion Gain (HCG) setting which is 
enabled by default in the Fluorescence mode.  This property setting is only visible when the 
camera model supports it.  When enabled the sensor produces a brighter output at a given 
exposure setting.   

The Fluorescence Mode now includes an optional Composite Editor function to enable post-
processing adjustments to the histogram stretch and cut-off controls.  Following the creation of 
a composite result in the Capture Sequence, a right-mouse click on the thumbnail image 
provides access to the Fluorescence Composite Editor, proving access to histogram 
adjustments and (X,Y) offset alignment of channels.  Additionally, the applied changes can be 
used to update the Fluorescence Channel settings. 

Adjustments to the performance of the White Balance have been implemented.  A new setting 
appears on the File > Preferences… > Display tab, to enable Digital Channel Gains to work in 
conjunction with the Analog gains.   

Issues Addressed 

An undesirable color shift could occur when a fluorescence channel was using a color Look Up 
Table (LUT) that was other than the standard Red, Green, or Blue.  The code has been 
corrected to eliminate the color shift for any selected color LUT. 

A duplicate Advanced Filenaming token had been introduced inadvertently.  One of the 
shortcut tokens for month has been reassigned to %NN, allowing the %MM to remain as an 
option for Minutes. 

The Verify Filename function now allows specification of an already existing filename.  The 
operator was previously forced to select a different filename, without an option to overwrite the 
existing one.   

The image Pan & Zoom functions have been enabled in the Fluorescence Capture Sequence 
image windows. 
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Previous Software Release – 7.0.3 

Date  February 16, 2021 
Windows 7.0.3.1111 
Mac 7.0.3.1111 

The following items have been addressed in the current release 

Improvements Implemented 

Workflow for single channel Fluorescence acquisitions has been streamlined.  Once a 
Sequence is started with a single channel defined and auto file saving enabled, the Capture 
button alone will complete an acquisition and file save, allowing for repeat images acquisitions 
by solely clicking Capture.  

Fluorescence image filename options include basic and advanced filename options.  User-
defined filename prefix and auto-naming variables can be incorporated 

Fluorescence image Capture Options allow choice to store Composite only, Raw channels 
only, or Processed channels only, or any combination of these acquisition files 

An option has been added to the Fluorescence Sequence to prevent advancement to the next 
Channel, when enabled.  This allows repetitive attempts to configure the same channel as 
desired, prior to moving to the next channel in the sequence 

Micrometer bar will redraw at the specified length when the calibration is adjusted.  Previously, 
the text label was being changed to match the original graphic’s scaled length. 

Control over the Preview Framerate is available through the File > Preferences… menu on the 
Display panel.  The option is available to limit the maximum Live View Refresh Rate to further 
reduce CPU usage.  The frame rate displayed in the Status Bar has been updated to show 
both the Live View display rate along with the frame rate being transferred from the camera. 

The 3-point circle measurement tool has been added to the Measure menu 

Measurement and Annotation graphics are now visible in the Magnifying Glass View window 

Manual counting now includes the ability to resume counting in one or more series placed in 
the image. 

INFINITY ANALYZE executable is signed and whitelisted by Antivirus software packages 

Image files can be opened in INFINITY ANALYZE using a drag and drop operation 

Line Color and Fill Color toolbar buttons now display an empty box when ‘no color’ is selected 

Image acquisition processing is handled by a separate thread, reducing the likelihood of 
apparent application lock-up during a long exposure image capture 

Import for all annotation objects in SIF file format images is now supported 

Options for the histogram presentation have been included in the File > Preferences dialog. 
The style, peak clipping, and transparency of the output can now be adjusted  

Issues Addressed 

Copy to Clipboard now includes any overlay graphics.  The function has moved under the Edit 
menu, or can be invoked with a right-mouse-click menu on an image window.  Color overlays 
are retained in images from monochrome cameras. 

Video clip capture now respects all combinations of the flip/mirror settings 
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A thread processing issue has been addressed, resulting in a reduction in CPU usage 
associated with the live preview 

Video clips are now recorded as .AVI files on Mac and as .WMV files on Windows 

Define LUT on Live View no longer has swapped controls for Red/Blue channels 

Burn In Annotations now available as an option for TIF and PNG formats, rather than only 
being an option for JPG and BMP formats previously  

Exposure logic corrected for INFINITY5-3 or INFINITY5-5 with an HDMI cable connected to a 
display.  The exposure time is no longer constrained to 16ms under this circumstance. 

Reset Extended Controls in Advanced Options now working on Mac 

Corrected issue that could result in prompt failing to appear after drawing a calibration line 

Extended the selection range for mouse clicks when choosing annotation and measurement 
objects 

Parameters associated with the display of Annotation and Measurement graphics are now 
persistent between sessions  

Improved the stabilization for the auto exposure modes of Mean & Peak making the exposure 
settle more effectively 

The Gallery has been adjusted to auto-scroll such that the most recent image acquisition is 
easily seen at the bottom of the items shown. 

Image properties stored as meta data with captured images now include the camera settings 
for Exposure & Gain. 

Removed delays impacting acquisition speed for 16-bit image capture 

Fluorescence Sequence Save As correctly updating the dropdown box with new entry 

Entries in the Fluorophores table are no longer being duplicated each time a new entry is 
added 

Temporary files are being correctly discarded when the application exits 

A dialog warns that the file type will be changed when annotations are added to the live 
preview and the file type is set to BMP or JPG, unless the burn-in annotations is enabled 

Choosing transparent for the line color no longer results in the dragged line being hidden 
during calibration  

Flat Field Correction has been improved to work more effectively with images from color 
cameras. 

Menu functions for Select / Select All / Delete of measurement or annotation graphics has been 
moved to appear under the Edit Menu. 

Fluorescence channel image windows now offset properly when generated 

Text annotation sizes are correctly preserved in image meta data 

The cursor uses an altered appearance when positioned within the selection range of the origin 
point, facilitating the closing off of Polygonal Regions 

The Calibration dialog remains visible when the calibration measurement is being placed 

Annotation text can immediately be entered when a new Annotation object is added to an 
image 

Manual counting annotations now respect the specified font size and line thickness 
adjustments  
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Known Issues 

The Record Video playback function on Mac is unable to recognize the AVI files generated.  It 
is necessary to use QuickTime or another 3rd-party tool to view the AVI video clips produced in 
ANALYZE on Mac.  

Rectangular and circular grid placements under the Measure menu have limited capabilities in 
this release.  There are no controls available to adjust the spacing.  The color and line 
thickness are the only alterations that can be made.  Additional adjustment controls for spacing 
will be included in a subsequent release. 

The Saturation Overlay utility will use a solid color to highlight saturated pixels.  The operation 
is currently able to identify only pixels that hit the (255,255,255) threshold values for R,G,B.  
Some older camera models may not be able to achieve the full 255 intensity on all channels, 
preventing the saturation marker from displaying.   

Previous Software Release – 7.0.2 

Date  January 10, 2020 
Windows 7.0.2.920 
Mac 7.0.2.920 

The following items have been addressed in the current release 

Issues Addressed 

The installation file for the Windows version of INFINITY ANALYZE 7 now includes the 
required camera device drivers and other supporting files.  This makes the installation for 
INFINITY ANALYZE 7.0.2 for Windows a stand-alone package that no longer relies on any 
other INFINITY package.  The Mac versions always include the required camera device 
drivers. 

The Annotation Edit toolbar is now displayed as part of the application’s default layout. 

Annotation and Measurement graphics are rendered with improved quality. 

Object Counting invoked from the Measure menu allows line color, line weight, and font 
preferences to be specified.  Changes take effect when the next counting sequence is initiated, 
whether in the live preview or in a captured image.  The counting operation must be completed 
using a double-left-mouse click, or by selecting the “hand” icon in the Annotate Toolbar.  The 
Measurements table is updated with a total object count each time a count operation is 
terminated. 

Graphic selection ‘handles’ are now scaled to be visible at the current zoom level, improving 
the selection and edit of annotation and measurement objects. 

The application launches with the last active Preset being enabled. 

The response of the Peak auto-exposure has been improved when recovering from a dark 
scene, as occurs when the objective turret is rotated on the microscope. 

The list of Calibrations includes a system calibration of <None> which uses image pixels for 
reference.   

Crosshairs has been relocated to the View menu 

Saturation overlay has been incorporated into the application and is accessible from the View 
menu.  In this release, the only overlay color supported is Red.  Additional color choices will be 
implemented later. 
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Different methods are available to close unwanted images.  From the File menu, Close All 
Images will remove images from the Gallery and closes any open image windows.  A right-
mouse-click in the Gallery offers the pop-up menu item Remove, which clears a single or 
multiple selected images from the Gallery.  From the main interface, a right-mouse-click offers 
the menu item Close All Image Windows, which removes the displayed image windows 
without clearing the copies stored in the Gallery. 

The response time for focus stacking has been improved, specifically when align images is 
active (used with stereoscopes).  However, during the Focus Stack processing, the application 
will not respond to mouse clicks or other interactions.  

Corrected the frame rate setting for the INFINITY1-2CB camera models on the Mac, where the 
overclocked frame rate was resulting in faint vertical sections being visible in the live preview.  

Icons for functions that were inactive in the Dark Theme were not distinguishable from those 
that were active.  The inactive icons are now displayed in a darker shade. 

The histogram display has been altered to keep the vertical scaling within a useful range when 
areas of the image become saturated. 

Corrected situations that might have caused instability or resulted in an application crash 
associated with either ‘Close all images’ or ‘Remove bad pixels’ operations. 

The File -> Open dialog now retains the folder location from the previously accessed images. 

Corrected an issue where a SIF file could be opened more than once to result in multiple 
instances of the same image being open. 

Annotations and measurements being burned into either a JPG or BMP output image are now 
clipped at the borders to retain correct image dimensions. 

Adjusted the Fluorescence Sequence Save As function to update the drop-down list correctly. 

An issue impacting the acquisition of images as TIFF 16-bit has been corrected. 

The User Guide document for v7.0.2 has been updated to reflect alterations made since the 
initial application release (7.0.0). 

Previous Software Release – 7.0.1 

Date  October 21, 2019 
Windows 7.0.1.870 
Mac 7.0.1.896 

The following items have been addressed in the current release 

Improvements Implemented 

The Flatfield Correction Operation occurs more efficiently, taking less time to complete. 

The information provided on the pop-up dialog after a failed White Balance operation is more 
informative. 

Micrometer bar dialog now retains settings associated with the Preset. 

Issues Addressed 

Micrometer Bar and Measurement Text labels font colors can now be modified using the 
Annotation Edit Toolbar. 

User Guide for Mac can now be displayed from the Help → Manual menu button. 



Teledyne Lumenera • 7 Capella Ct. Ottawa, ON, Canada K2E 8 A7 • (t) 1.613.736.4077 • (f) 1.613.736-4071 • www.teledynelumenera.com 
Teledyne Lumenera, all rights reserved. Prices, features, and specifications are subject to change without notice.  

The Peak auto exposure mode now responds more quickly when recovering from an over-
exposed scene. 

Counting measurements are no longer duplicated on a save/load operation. 

Angle measurement values now display the units. 

The camera Saturation is no longer set to minimum when importing Presets from ANALYZE 6. 
This was resulting in the color image being displayed in grey scale until the Saturation value 
was manually adjusted. 

The control for the camera cooling was missing for the INFINITY3-1 model (impacts cooled 
cameras only). 

Native SIF file format images from version 6.5.5 (and earlier) can now be imported into version 
7, using the File → Convert File Format operation. 

A Micrometer bar can now display a length in pixels and will not accept other units without an 
active calibration. 

Functions associated with creating new Fluorescence Sequences will no longer overwrite 
existing Sequences. 

The path to USB2.0 camera model device drivers on Mac have been corrected (impacted 
INFINITY1-2CB, INFINITY1-3). 

The Navigation Panel is no longer visible within the video playback for the in-App Help 
Tutorials. 

A required video playback codec has been included in the installation for systems where it was 
not already present. 

Initial Software Release – 7.0.0 

Date  September 23, 2019 
Windows 7.0.0.839 
Mac 7.0.0.852 




